Name: Frederik Orellana (email_not_shown)
Date: 04/30/04-11:13:01 AM Z


CreateFCAmp was created for Classes amplitudes (see also ?CreateFCAmp).
Particles and Generic levels are not supported. Should not be hard to
extend though - there just never were any requests before. (Any one else
interested in this feature?) You might try with CreateFeynAmp and then
apply FAToFC.

Cheers, Frederik

Jon Palmer wrote:
> I am having some issues using the CreateFCAmp function specifically
> specifying the level at which the fields are calculated.
>
> For various reasons I want to only insert fields at the "{Particles}" level.
> However when I then run CreateFCAmp on those inserted fields I get an error
> from CreateFeynAmp. With $VeryVerbose on high it prints
>
> "creating amplitudes at level(s) {Generic, Classes}"
>
> and then reports two errors
>
> "CreateFeynAmp::nolevel: Warning: Level Generic is not contained in this
> insertion."
> "CreateFeynAmp::nolevel: Warning: Level Classes is not contained in this
> insertion."
>
> as the inserted fields at both the Generic and Classes levels are obviously
> empty. I believe that CreateFeynAmp is supposed to default to the level at
> which the fields are inserted but that doesn't appear to happen when it is
> called through CreateFCAmp (No such error results if I call CreaateFeynAmp
> directly on the inserted fields). I have also tried to force the issue by
> specifying "AmplitudeLevel -> {Particles}" as an option for CreateFCAmp but
> it makes no difference. Any thoughts as to why it behaves like this and how
> it might be rectified?
>
> Many thanks,
> Jon Palmer
>
>



This archive was generated by hypermail 2b29 : 02/23/17-08:00:01 AM Z CET